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Abstract 
The OpenModelica (MDT) Eclipse Plugin integrates 
the OpenModelica compiler and debugger with the 
Eclipse Integrated Development Environment Frame-
work.. MDT, together with the OpenModelica compiler 
and debugger, provides an environment for Modelica 
development projects. This includes browsing, code 
completion through menus or popups, automatic inden-
tation even of syntactically incorrect models, and 
model debugging. Simulation and plotting is also pos-
sible from a special command window. To our knowl-
edge, this is the first Eclipse plugin for an equation-
based language. 

1 Introduction 
The goal of our work with the Eclipse framework inte-
gration in the OpenModelica modeling and develop-
ment environment is to achieve a more comprehensive 
and more powerful environment. It can be useful to 
first take a general look at this area including some 
background. 

1.1 Integrated Interactive Programming Envi-
ronments 

An integrated interactive modeling and simulation en-
vironment is a special case of programming environ-
ments with applications in modeling and simulation. 
Thus, it should fulfill the requirements both from gen-
eral integrated environments and from the application 
area of modeling and simulation mentioned in the pre-
vious section. 

The main idea of an integrated programming envi-
ronment in general is that a number of programming 
support functions should be available within the same 
tool in a well-integrated way. This means that the func-
tions should operate on the same data and program rep-
resentations, exchange information when necessary, 
resulting in an environment that is both powerful and 
easy to use. An environment is interactive and incre-

mental if it gives quick feedback, e.g. without recom-
puting everything from scratch, and maintains a dia-
logue with the user, including preserving the state of 
previous interactions with the user. Interactive envi-
ronments are typically both more productive and more 
fun to use.  

There are many things that one wants a program-
ming environment to do for the programmer, particu-
larly if it is interactive. What functionality should be 
included? Comprehensive software development envi-
ronments are expected to provide support for the major 
development phases, such as: 

• Requirements analysis. 
• Design. 
• Implementation. 
• Maintenance. 

A programming environment can be somewhat more 
restrictive and need not necessarily support early 
phases such as requirements analysis, but it is an ad-
vantage if such facilities are also included. The main 
point is to provide as much computer support as possi-
ble for different aspects of software development, to 
free the developer from mundane tasks, so that more 
time and effort can be spent on the essential issues. The 
following is a partial list of integrated programming 
environment facilities, some of which are already men-
tioned in (Sandewall 1978 [11]), that should be pro-
vided for the programmer: 

• Administration and configuration management of 
program modules and classes, and different versions 
of these. 

• Administration and maintenance of test examples 
and their correct results. 

• Administration and maintenance of formal or in-
formal documentation of program parts, and auto-
matic generation of documentation from programs. 

• Support for a given programming methodology, e.g. 
top-down or bottom-up. For example, if a top-down 
approach should be encouraged, it is natural for the 
interactive environment to maintain successive 
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composition steps and mutual references between 
those. 

• Support for the interactive session. For example, 
previous interactions should be saved in an appro-
priate way so that the user can refer to previous 
commands or results, go back and edit those, and 
possibly re-execute. 

• Enhanced editing support, performed by an editor 
that knows about the syntactic structure of the lan-
guage. It is an advantage if the system allows edit-
ing of the program in different views. For example, 
editing of the overall system structure can be done 
in the graphical view, whereas editing of detailed 
properties can be done in the textual view. 

• Cross-referencing and query facilities, to help the 
user understand interdependences between parts of 
large systems. 

• Flexibility and extensibility, e.g. mechanisms to ex-
tend the syntax and semantics of the programming 
language representation and the functionality built 
into the environment.  

• Accessible internal representation of programs. This 
is often a prerequisite to the extensibility require-
ment. An accessible internal representation means 
that there is a well-defined representation of pro-
grams that are represented in data structures of the 
programming language itself, so that user-written 
programs may inspect the structure and generate 
new programs. This property is also known as the 
principle of program-data equivalence. 

Early work in interactive integrated programming envi-
ronments supporting a specific language was done in 
the InterLisp system for the Lisp language: (Teitelman 
1974 [12]), common principles and experience of early 
interactive Lisp environments are described in (Sande-
wall 1978 [11]), interactive and incremental Pascal 
with the DICE system: (Fritzson 1983 [3]), the inte-
grated Mjölner environment, (Lindskov, Knudsen, 
Lehrmann-Madsen, and Magnusson 1993 [9]). 

1.2 The Eclipse Framework 

Eclipse [1] is an open source framework for creating 
extensible integrated development environments 
(IDEs). (For the history of Eclipse, see Section 6). One 
of the goals of the Eclipse platform is to avoid duplicat-
ing common code that is needed to implement a power-
ful integrated environment for development of soft-
ware. By allowing third parties to easily extend the 
platform via the plugin concept, the amount of new 
code that needs to be written is decreased.  

1.3 Eclipse Platform Architecture 

By itself, Eclipse does not provide much end-user func-
tionality. The important contributions to Eclipse are 
based on its plugins. The smallest architectural unit of 
the Eclipse platform is the plugin. 

At the core of Eclipse is the Eclipse Platform Run-
time. The Runtime in itself mostly provides the loading 
of external plugins. The Java Development Tooling 
(JDT) is for example a collection of plugins that are 
loaded into Eclipse when they are requested. The fact 
that Eclipse is in itself written in Java and comes with 
the Java Development Tooling as default often leads 
newcomers to believe that Eclipse is a Java IDE with 
plugin capabilities. It is in fact the other way around, 
with Eclipse being just a base for plugins, and the Java 
Development Tooling plugging into this base. 

To extend Eclipse, a set of new plugins must be cre-
ated. A plugin is created by extending a certain exten-
sion point in Eclipse. There are several predefined ex-
tension points in Eclipse, and plugins can provide their 
own extension points. This means that you can plug in 
plugins into other plugins. 

An extension point can have several plugins at-
tached, and the plugin that will be used is determined 
by a property file. For example, the Modelica Editor is 
loaded at the same time as the Java Editor is loaded. 
When a user opens a Java file, the Java Editor will be 
used, based on a property in the Java Editor extension. 
In this case, it is the file name extension that selects 
what editor should be used. 

As the number of plugins in Eclipse can be very 
large, a plugin is not actually loaded into memory be-
fore its contribution is directly requested by the user. 
This design makes the memory impact reasonably low 
while running Eclipse. 

A user-friendly aspect of Eclipse is the Eclipse Up-
date Manager which allows the user to install new 
plugins just by pointing Eclipse to a certain website. 
This website is provided by the developers of the 
plugin that the user may wish to install. An update site 
at the OpenModelica [13] web site is for example pro-
vided for easy installation of the latest version of MDT. 

1.4 OpenModelica MDT Plugin into Eclipse 

The MDT Eclipse plugin provides file and class hierar-
chy browsing and text editing capabilities. Syntax high-
lighting facilities and a compilation manager are also 
included in MDT, as well as integration of the debug-
ger for the algorithmic Modelica code. 
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Figure 1.  The architecture of Eclipse, with possible plugin 
positions marked. 

 

The Eclipse framework (Figure 1) has the advantage of 
making it easy to add future extensions.  

2 OpenModelica Environment Archi-
tecture 

The MDT Eclipse plugin is integrated in the Open-
Modelica environment which consists of several inter-
connected subsystems, as depicted in Figure 2 below. 
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Figure 2.  The architecture of the OpenModelica  
environment.  

Arrows denote data and control flow. Several subsys-
tems provide different forms of browsing and textual 
editing of the Modelica code.  

OpenModelica is structured as several communicat-
ing processes in client-server architecture, primarily 
exchanging information through a Corba interface, see 
Figure 3. The OpenModelica compiler/interpreter 
(OMC) is the server, communicating with clients. The 
Eclipse MDT plugin is one of the clients. 
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Figure 3.  The client-server architecture of the 
OpenModelica environment.  

Messages from the Corba interface are of two kinds. 
The first group consists of expressions or user com-
mands which are evaluated by the Ceval module. The 
second group includes declarations of classes, vari-
ables, etc., assignments, and client-server API calls that 
are handled via the Interactive module, which also 
stores information about interactively declared/assigned 
items at the top-level in an environment structure 

3 Modelica Development Tooling 
(MDT) Eclipse Plugin 

As mentioned, the Modelica Development Tooling 
(MDT) Eclipse Plugin provides an environment for 
working with Modelica development projects. 

The following features are available: 

• Browsing support for Modelica projects, pack-
ages, and classes. 

• Wizards for creating Modelica projects, 
packages, and classes. 

• Syntax color highlighting. 
• Syntax checking. 
• Code completion when writing code to 

reference a class. 
• Code completion/signature information when 

writing function calls. 
• Browsing of the Modelica Standard Library and 

other Modelica package hierarchies. 
• Support for MetaModelica extensions to 

standard Modelica. 
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3.1 Using the Modelica Perspective 

The most convenient way to work with Modelica pro-
jects is to use to the Modelica perspective. To switch to 
the Modelica perspective, choose the Window menu 
item, select Open Perspective followed by 
Other... Select the Modelica option from the dialog 
presented and click OK. 

3.2 Creating a Project 

To start a new project, use the New Modelica Pro-
ject Wizard. It is accessible through File->New-> 
Modelica Project or by right-clicking in the Mode-
lica Projects view and selecting New->Modelica 

Project. 

 
Figure 4. Creating a new package. 

3.3 Creating a Package 

To create a new package inside a Modelica project, 
select File->New->Modelica Package. Enter the 
desired name of the package and a description of what 
it contains. 

3.4 Creating a Class 

To create a new Modelica class, select where in the 
hierarchy that you want to add your new class and se-
lect File->New->Modelica Class. When creating a 
Modelica class you can add different restrictions on 
what the class can contain. These can for example be 
model, connector, block, record, or function.  

When you have selected your desired class type, 
you can select modifiers that add code blocks to the 
generated code. ‘Include initial code block’ will 
for example add the line ‘initial equation’ to the 
class. 

 

 
Figure 5. Creating a new class. 

3.5 Syntax Checking 

Whenever a Modelica (.mo) file is saved by the Mode-
lica Editor, it is checked for syntactical errors. Any er-
rors found are added to the Problems view and also 
marked in the source code editor.  

 
Figure 6. Syntax checking. 

Errors are marked in the editor as a red circle with a 
white cross, a squiggly red line under the problematic 
construct, and as a red marker in the right-hand side of 
the editor. To reach the problem, one can either click 
the item in the Problems view or select the red box in 
the right-hand side of the editor. 

3.6 Code Completion 

MDT supports Code Completion in two variants. The 
first variant, code completion when typing a dot after a 
class (package) name, shows alternatives in a menu: 
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Figure 7. Code completion using a popup menu after a dot 

The second variant is useful when typing a call to a 
function. It shows the function signature (formal pa-
rameter names and types) in a popup when typing the 
parenthesis after the function name, here the signature 
Real sin(SI.Angle u) of the sin function: 

 
Figure 8. Code completion showing a popup function 
signature after typing a left parenthesis.  

3.7 Automatic Indentation 

MDT has recently obtained support for automatic in-
dentation. When typing the Return (Enter) key, the next 
line is indented correctly. You can also correct indenta-
tion of the current line or a range selection using 
CTRL+I or “Correct Indentation” action on the toolbar 
or in the Edit menu.  

Indentation can be applied to incomplete code as a 
heuristic Modelica scanner is used and the indentation 
is based only on the tokens generated by this scanner. 
The indenter indents one line at a time. For example, 
consider that line four (4) in Figure 10 should be in-
dented. The indenter asks the heuristic scanner to give 
tokens from the starting token in backwards direction to 
the start of the file until a scope introducer is recog-
nized, which for this particular file is model MoonAn-
dEarth.  The reference position of the start of the 
scope introducer is computed and line four (4) is in-
dented from this reference position one indent unit. The 
indentation result is presented in Figure 10. 

Indenting Modelica code is far from trivial when in-
complete (possibly incorrect) code should be indented 
correctly. Most of the difficulty comes from Modelica 

scopes which are hard to recognize using just a scanner 
and some logic behind it. In languages like C/C++ and 
Java finding enclosing scopes is very easy as one char-
acter tokens are used for the scope opening and closing: 
"{" and "}". In Modelica you need at least two tokens 
and much more case analysis to find where a scope 
starts and ends. Complications also arise when mixing 
if-statements with if-expressions (which was further 
complicated by the introduction of conditional declara-
tions in the Modelica language). In this particular case 
we implemented a parser emulator that recognizes these 
constructs based on scanner tokens delivered back-
wards.  

 
Figure 9.  Example of code before indentation. 

 
Figure 10. Example of code after automatic indentation. 

The indenter works in almost all cases, but there are 
cases in which is impossible to find the correct indenta-
tion. For example when the indentation of a line con-
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sisting of "end Name;" is requested and the scope 
introducer for Name is not found (that is identifier Name 
followed backwards by class, model, package, 
block, record, connector etc.) then the indenter 
fails and returns the indentation of the previous line.       

4 The OpenModelica Debugger Inte-
grated in Eclipse 

We have integrated our debugger for algorithmic Mod-
elica code (Adrian Pop and Peter Fritzson, 2005 [10]) 
within the Eclipse debugging framework.  

The communication protocol between MDT and the 
debugger (which is included in the compiled executable 
built for simulation) is based on a client-server archi-
tecture and is implemented via sockets. The debugger 
is the server and MDT is the client.  

When the debugged model is simulated, the debug-
ger receives from MDT all the breakpoints set within 
the algorithmic code. Then the debugger resumes the 
application program. When a breakpoint condition be-
comes true the debugger stops the program and listens 
to commands it may receive from MDT. The com-
mands accepted by the MDT client are classic: variable 
value printing, stack trace printing, stepping, running, 
etc. MDT sends appropriate commands to the debug-
ger, parses the information received and displays it 
within the MDT debugging views to be inspected by 
the programmer.  

Because algorithmic code can be executed millions 
of times within a simulation, it is very important to be 
able to specify breakpoints based on variable values 
and/or the number of times a function executes. These 
types of breakpoints were recently added to the debug-
ging framework previously described in (Adrian Pop 
and Peter Fritzson, 2005 [10]) and are now available, 
also in MDT within Eclipse.  

5 Simulation and Plotting from MDT 
Simulation and plotting is possible from a special 
command window, where commands are sent to omc. 
For example: 

Simulation: 
>> simulate(Influenza,startTime=0.0, 
stopTime=3.0) 
record 
    resultFile = "Influenza_res.plt" 
end record 

The simulated population is plotted (Figure 11). 
>> plot({Infected_Popul.p}) 
true 
 

 
Figure 11. Plot of the Influenza model. 

6 Eclipse History 
In the mid 1990s software developments tools were 
primarily dominated by systems built around two tech-
nologies. Many of the tools were focused on a runtime 
environment developed and controlled by the Microsoft 
Corporation. The other was built around the Java plat-
form. The Java platform is less dominated by a single 
company and more open to industry and community 
input. IBM felt it was important to contribute to the 
growth of the more open Java platform to become in-
dependent of Microsoft.  

By creating a common platform for development 
tools built on top of the Java platform, IBM hoped to 
attract more developers from competing environments. 
In late 1998, the software division at the IBM Corpora-
tion began working on the software project that is today 
known as Eclipse. The original work was based on re-
sources developed by Object Technology International 
labs. In the beginning, the work on a new Java IDE was 
performed at the IBM laboratories. At the same time 
additional teams were setup by IBM to build other 
products on top of the platform. 

In order to increase the rate of adaptation of the 
platform and to instill confidence in the Eclipse plat-
form, IBM decided to release the code base under an 
open source license, and to build a community around 
the project. 

In 2001, IBM together with eight other organiza-
tions created the Eclipse consortium. A website at 
eclipse.org was started in order to create and coor-
dinate a community around Eclipse. The goal was that 
source code would be controlled and developed by the 
open source community and the consortium would 
handle the marketing and business side of the project. 

At that point, IBM was the largest contributor to 
both the open source community and the consortium. 
Two years later the first major public release of the 
Eclipse platform was made. The release got a lot of 
attention from developers and was well received. How-
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ever, industry analysts suggested that many still per-
ceived Eclipse as an IBM-controlled technology. Many 
key players in the industry did not want to make com-
mitments to a project controlled by the International 
Business Machines Corporation. 

After discussions within the consortium it was de-
cided that a new organization was needed to make the 
status of Eclipse as an open and community driven pro-
ject clear. At the EclipseCon 2004 gathering an an-
nouncement was made that the Eclipse Foundation was 
formed. The foundation is an independent not-for-profit 
organization. It has its own full time paid professional 
staff, supported by foundation members. 

The new organization has proven itself a success. At 
this point the foundation have released version 3.0 and 
3.1 of Eclipse since its birth. These releases have 
gained more adoption and recognition than any earlier 
versions. Today (2005) the foundation has more than 
90 full-time developers on the pay roll and receives 
more than $2 millions in funding each year. 

Currently there are more than eighty member com-
panies in the foundation of which at least sixty-nine are 
providing add-on products to Eclipse. Today there ex-
ists hundreds of proprietary and an even greater number 
of free plugin products. Eclipse has gained a strong 
foothold in the industry and is one of the major open 
source software development platforms [2]. 

7 Conclusion 
The OpenModelica integrated development environ-
ment for Modelica has been augmented with a plugin to 
the Eclipse framework. The plugin, called MDT (Mod-
elica Development Tooling) [13], an earlier version is 
described in [14], is primarily aimed at development of 
large models. It has support for browsing, editing, code 
completion, automatic indentation, building executa-
bles, and debugging. It also allows simulation and plot-
ting from a special command window. To summarize, 
it provides a rather complete integrated development 
environment, and it is also the first available Eclipse 
plugin for an equation-based language. 
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